HomeSUPPORT QUESTIONS

Need help with StresStimulus? Start here.

Important requests only being sent once when caching is enabled Messages in this topic - RSS

Brianna Blanchard
Brianna Blanchard
Posts: 76


7/29/2013
My set up is as follows: log in on first iteration, load a couple pages all iterations, logout out on last iteration. Caching is enabled (with 100%) new VU to allow the sessions established upon each VU first logging in to persisent across iterations. The most important page consistent of a primary, initializing request following by a series of (parameterized) image requesets. However, despite the fact that this page is set to be requested for "All iterations", only the primary request is being sent after the first iteration. When I turn off caching, the requests are made every iteration. It thus appears that SS has determined that these requests are static images that do not need to be requested again, despite the fact that I have parameterized these image requests.

In the description for the New VU%, it says "Caching rules for each request will be determined based on server caching headers." Is there something I can modify in the original requests to get these requests replayed every time? I really need to be able to use caching.

I will upload my test to the support repository.
0 link
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101


7/30/2013
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101
SS has determined that these requests are static images that do not need to be requested again, despite the fact that I have parameterized these image requests


Correct.  We will make requests  with dynamic urls not-cacheable. I added this feature here

Here is the workaround that you can use for now:

  1. Select the group of requests in the grid.



  1. Drag-and-drop them to the test case tree below the original requests. You should now have the original requests and the cloned requests. The cloned requests have caching disabled.



  1. Now delete the original requests.

  2. You will have to re-parameterize the cloned requests.

0 link
Brianna Blanchard
Brianna Blanchard
Posts: 76


7/30/2013
Thank you for adding a feature request. We ended up modifying the response from our web service to explicity state that it shouldn't be cached, since I really needed to take the data. I haven't tried your workaround, but it is similar to some workarounds I tried that definitely didn't work, so if I do end up trying it, I'll be sure to follow the steps exactly (and let you know the results).
0 link
Brianna Blanchard
Brianna Blanchard
Posts: 76


8/9/2013
I'm not sure what I was doing differently the first time I tried something like this, but duplicating the requests, deleting the old ones, and re-parameterizing fixed the issue.
0 link
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101


8/13/2013
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101
Thank you for letting me know. We just released an update that allows configuring request caching. Check item 4 in this post.
0 link






Copyright © 2017 Stimulus Technology