HomeSUPPORT QUESTIONS

Need help with StresStimulus? Start here.

Unable to start execution Messages in this topic - RSS

vivek goyal
vivek goyal
Posts: 16


8/26/2015
vivek goyal
vivek goyal
Posts: 16
Hi,

I have downloaded stresstimulus trial version to perform POC for one of my client. After recording and load test scenario creation and i click on start load test button it will ask for dubug or without debug. When i click on debug option and click on start it execute test successfully but when i click on start button without selecting debug execution went in waiting position after 15% of processing. I trid multiple times but still getting the same problem. Can somebody please help me to remove this situation.
0 link
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101


8/26/2015
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101
Hi Vivek,
One of the reasons that a test can seemingly stop at a certain point is server inability to keep up with sending timely responses. Here's how it works. Virtual users, like physical browsers, send subsequent requests after receiving responses back from the server. Once the number of pending requests exceeds certain level (specific to the emulated browser) the VU will wait until the responses are received, or a timeout occurred.

To check if this is the case in your situation, look at the Requests Pending counter in the Test Progress Panel described here http://support.stresstimulus.com/display/doc42/Monitoring+the+Test and shown below:


 
If this counter does not decrement, then the server is slow to respond. In this is the case, you have a few options.
1.    Reduce the number of VUs so your server and can keep up with the amount of load from StresStimulus.
2.     Reduce the default page timeout value located in the Workflow Tree-> Test Case Settings. The default value is 120 seconds. It is described here:
http://support.stresstimulus.com/display/doc42/Page+Timeout


If none of these will help, you're welcome to schedule a support WebEx session, and we will assist you. I just sent you a scheduling link in a private message.
 
Cheers,
-Max
0 link
vivek goyal
vivek goyal
Posts: 16


8/26/2015
vivek goyal
vivek goyal
Posts: 16
Hi Max,
Thanks for the response. I have dubug this problem little bit more. I tried to execute this test using fiddller and found that after 15% completion it through one exception. Screenshot of the exception is also attached here. After this i tried to record new script and execute it it works fine. Then i have added respons validator in 2-3 requests and again the same problem started coming. So i think this problem is something related to response validator. Can you please help me in this.

Max K said:
Hi Vivek,
One of the reasons that a test can seemingly stop at a certain point is server inability to keep up with sending timely responses. Here's how it works. Virtual users, like physical browsers, send subsequent requests after receiving responses back from the server. Once the number of pending requests exceeds certain level (specific to the emulated browser) the VU will wait until the responses are received, or a timeout occurred.

To check if this is the case in your situation, look at the Requests Pending counter in the Test Progress Panel described here http://support.stresstimulus.com/display/doc42/Monitoring+the+Test and shown below:


 
If this counter does not decrement, then the server is slow to respond. In this is the case, you have a few options.
1.    Reduce the number of VUs so your server and can keep up with the amount of load from StresStimulus.
2.     Reduce the default page timeout value located in the Workflow Tree-> Test Case Settings. The default value is 120 seconds. It is described here:
http://support.stresstimulus.com/display/doc42/Page+Timeout


If none of these will help, you're welcome to schedule a support WebEx session, and we will assist you. I just sent you a scheduling link in a private message.
 
Cheers,
-Max



0 link
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101


8/26/2015
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101
Vivek, 
Thanks for your detailed update. You're right that the exception was thrown by the validators. It was possibly caused by applying a validator to an empty or corrupt response body.
We fixed the issue .  The fix will be included it in the next StresStimulus build after a complete regression testing cycle. 
In the meantime, we issued a hotfix that is available here
http://update.stimulustechnology.com/stresstimulus/StresStimulusInstaller_fix.exe
 
 Let me know how it goes.
Cheers,
-Max
0 link
vivek goyal
vivek goyal
Posts: 16


8/27/2015
vivek goyal
vivek goyal
Posts: 16
Thanks Max for your prompt response and updated build. Now i am able to record my flow.
Just one more question i have that for my POC purpose i need license of 15-20 user so that we can show it to client. Can we get it on trial version so that we can complete our POC. In case it goes well then might be we need license of this tool. 
0 link
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101


8/27/2015
Max @StresStimulus
Max @StresStimulus
Administrator
Posts: 101
You're welcome Vivek and thank you again for reporting the issue on the forum. 
To get a trial license, please register here https://www.stresstimulus.com/trials/request-trial
You will receive an extendable 7-day activation key, which you can renew after it expires.
Cheers,
-Max
0 link
vivek goyal
vivek goyal
Posts: 16


8/27/2015
vivek goyal
vivek goyal
Posts: 16
Thanks Max for your response. I will register on this link.
0 link






Copyright © 2017 Stimulus Technology