HomeSUPPORT QUESTIONS

Need help with StresStimulus? Start here.

Requested Transaction with Errors Messages in this topic - RSS

mwatte
mwatte
Posts: 9


28 days ago
mwatte
mwatte
Posts: 9
I am trying to understand Requested Transaction with Errors. I understand the Missed Goals.




My load test returned an error request which I can't seem to hunt down. I was reading information about Hidden Errors and can't find anything doing a comparison...everything returned a green checkmark with no warnings and/or notifications.

I read in another forum that I should probably increase the default timeout which I did but that didn't resolve the error. Also, went into debug mode and I'm not seeing any errors in the sessions.


I am using StresStimulus standalone version testing an Oracle ADF application. Is there anything else I can do the find this one error?

Another weird thing I found with client certificates is that not all users authenticate even though I am load testing with 10 VUs and I have 10 certificates. Sometimes it works, most of the time it doesn't. From the report, it appears one user is used twice in a "login request" to make it equal up to 10 VUs. So I'm not understanding the inconsistency. I wish I can share my test but due to confidential information, I am not able to.
0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


27 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
Your screenshot shows that you are looking at a transaction sub-report that had 1 error. To see the error details, go back to the test report and see the Error view described here.

Increasing the default timeout threshold will not help your situation because you seemingly did not have any timeouts.

The issue with not all 10 VUs authenticating is probably caused by concurrency errors. If you are able to authenticate each VU individually though the verify process, then maybe your application can’t handle 10 simultaneous logins. One of the purposes of load testing is actually detecting concurrency errors so they can be addressed. Try running a fewer number of concurrent VU and note the number of passed and failed logins. It may help you to determine how many concurrent logins your application supports.

-Cheers
0 link
mwatte
mwatte
Posts: 9


27 days ago
mwatte
mwatte
Posts: 9
George - thank you for your response. Really appreciate you taking the time to help.


The Error view is currently grayed out which is why I resorted to the forum. See below screenshot.

Also, if my application couldn't handle 10 users simultaneously, why would all 10 users concurrently authenticate 10% of the time but 90% of the time, it would only successfully authenticate 8? I know it's hard to troubleshoot without seeing the actual test case, but I wanted to ask here to see if this ever happened to anyone else and how it was resolved.

smile

0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


26 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
What version of StresStimulus are you currently using?

The version can be found in main menu > Help > About... dialog

- Cheers
0 link
mwatte
mwatte
Posts: 9


22 days ago
mwatte
mwatte
Posts: 9
The version is 5.2.7332 beta x64 CLR 4.0

Thank you George.
0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


22 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
It looks like you are using an older 5.2 beta version. The issue with grayed out Error view was fixed in a subsequent release. Please install the latest version of 5.2 beta from here

Then try running the test one more time. If you get the test execution error again, you would be able to see its details.

- Cheers
0 link
mwatte
mwatte
Posts: 9


13 days ago
mwatte
mwatte
Posts: 9
For the issue I was having with multiple client certificates authenticating all users 10% of the time but 90% of the time, only some users, what is required to troubleshoot that issue? Since our company purchased a license, I would like to know how to get this resolved especially when we start to add more client certificates for one of our applications.

Thanks.
0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


12 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
If your test report shows errors in your 5.2 beta version and you installed the update that I suggested, then you should be able to see error details in the Error view that should indicate failed requests or transactions.


If your test report does not show HTTP errors, but you determined that some logins failed, you can create response validators to narrow down to a specific failed request


If the tool determined that a certain percentage of logins fails under load, then your application scalability must be inspected.


If you have a more specific question that you cannot disclose on the public forum, you can contact your support rep or email support@stresstimulus.com, and they will assist you.


- Cheers
0 link
mwatte
mwatte
Posts: 9


12 days ago
mwatte
mwatte
Posts: 9
Will do. Thank you
0 link
mwatte
mwatte
Posts: 9


7 days ago
mwatte
mwatte
Posts: 9
George -

The client certificate feature is not working in the latest beta version you asked me to download. It's not finding the certs even thought I have it set up as described here, http://support.stresstimulus.com/display/doc52/_Authentication. The Certificates box is checked. I've tested this a few times even on 2 different machines.

The feature works fine when I reverted back to the version, 5.2.7332 beta x64 CLR 4.0.
0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


7 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
The latest beta version is v5.2.7395. It is available here https://www.stresstimulus.com/download

Make sure that you use it and post here if you can replicate the issue with multiple client certificates.

- Cheers
0 link
mwatte
mwatte
Posts: 9


6 days ago
mwatte
mwatte
Posts: 9
The Client Certificate feature in the latest beta version (v5.2.7395) is still not working.


Here is a screenshot of the version


Here is the Authentication view showing the Certificates box checked and the certificate (.cer) file. Again, I do have a folder of this certificate, placed in the correct directory per the instructions here, http://support.stresstimulus.com/display/doc52/_Authentication.


Here is the Load Pattern view


Here is the screenshot showing that out of the 20 requests, all 20 requests failed


Thank you.
0 link
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260


4 days ago
George @StresStimulus
George @StresStimulus
Administrator
Posts: 260
I checked with development and they cannot replicate any issues with the Client Certificate authentication. The issue you are experiencing may be caused by your application login instability under load.


You can contact your support rep to get your script checked.


- Cheers
0 link






Copyright © 2020 Stimulus Technology