HomeBUGS & ISSUES

Think you found a bug? Report it here.

"On Last iteration" doesn't work properly Messages in this topic - RSS

Bartosz Staniszewski
Bartosz Staniszewski
Posts: 7


12/31/2012
***Question was answered on 01/03/13 ***
Hello!
It seams to me that "On Last iteration" feature available in a page configuration doesn't work at all. I mark last page (in my case - logout) with this property and it is still run on every iteration.

Other options: "On 1-st iteration" and "All iterations" works perfectly :-)
 
I'm using Version 2.5.4743 beta.
 
Regards, 
 
Bartek
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


12/31/2012
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Bartek,
Thanks for reporting the issue with "On Last iteration". Will double check  and let you know the status.
Cheers,
-Vadim


0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


1/2/2013
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Bartek,
I double checked that the "On Last iteration" feature seems to work as designed. When "Test Duration" is set to "Number of Iterations ",


then pages marked "On Last iteration" (eg. log-off), run once, as specified in the application help.

However, when "Test Duration" is set to "Run Duration", then the log-off pages do not run at all, since StresStimulus completes the test after certain time elapsed and does not have a chance to run logoff pages for every user.
I was unable to replicate the behavior when the log-off runs on every iteration, as you described.
Please let me know if you still see this issue and I will investigate further.

Cheers,
-Vadim
0 link
Bartosz Staniszewski
Bartosz Staniszewski
Posts: 7


1/3/2013
Hi Vadim!

I made one more test with this - see attached test file. I still have same effect - it seams that second request is still run on every (2) iteration:


And there, how it is configured:
Regards, 
Bartek
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


1/3/2013
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Bartek,
ssconfig file that you attached does not have enough information for us to troubleshoot.  Would it be possible for you to upload your test case to our support secure repository? To do so, in StresStimulus main menu -> "support options",  select " upload support case".
Thank you,
-Vadim

0 link
Bartosz Staniszewski
Bartosz Staniszewski
Posts: 7


1/3/2013
Done :-)
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


1/3/2013
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Bartek,
Got it and found the issue with the test configuration.
For "On Last iteration" to work correctly, the "Number of iterations" settings should be set "per VU". So, instead of setting 80 combined iterations for two VUs, set 40 iterations per VU. In the first case, the 80 iterations will be divided between users not necessarily evenly, because the faster VU will run more iterations. As a consequence of this, StresStimulus cannot determine the last iteration for each VU.

In the next release will add a warning to guide users to a correct configuration.

Cheers,
-Vadim



0 link
Bartosz Staniszewski
Bartosz Staniszewski
Posts: 7


1/3/2013
Ok! I got the point now! You are right - warning could help :-)
Thank you for help!
Regards, 
Bartek


0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


1/3/2013
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
You're welcome, Bartek.
-Vadim
0 link






Copyright © 2017 Stimulus Technology