HomeSUPPORT QUESTIONS

Need help with StresStimulus? Start here.

401 errors on SAP BPC V10 Messages in this topic - RSS

Wietse Mol
Wietse Mol
Posts: 4


11/2/2012
Wietse Mol
Wietse Mol
Posts: 4
I'm trying to run a load test on my SAP BPC V10 server, but all the requests are returned as 401 errors. The application is working with integrated security, allthough in the requests I also see kerebos authentication

I have provided SressStimulus with a valid userid and password, that I can also see appear in the requests.

Any ideas? Any experience on SAP BPC?

Thanking you in advance,

Kind regards,
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


11/2/2012
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Hi Wietse,
We have customers using StresStimulus with SAP BPC.

If  you use Windows Integrated authentication over SSL in your configuration, then the 401 error is caused by the Fiddler authentication issue, impacting a test case recording. It is described in this post http://www.stresstimulus.com/forum/windows-integrated-authentication-over-ssl-341 
You would need to modify the Fiddler script to fix it.

Cheers,
-Vadim
0 link
Wietse Mol
Wietse Mol
Posts: 4


11/5/2012
Wietse Mol
Wietse Mol
Posts: 4
Hi vadim, tx for your reply. I did have a look at that post before I made a post myself, we are not using https. Do you think it is a good idea anyway to add this code?

Thanking you in advance,

Kind regards,
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


11/5/2012
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Wietse,
Since you do not use https, the channel binding tokens should not be an issue, and you do not need the above workaround. Instead let's isolate the authentication problem.

Do you receive the 401 during the recording or during the replay? If the recording works fine and the 401 comes up during the verification, then make sure to enter correct user credentials (domain, username and password) in the Authentication section, before running "Verify", as shown below.



Let me know how it goes.

-Vadim
0 link
Wietse Mol
Wietse Mol
Posts: 4


11/6/2012
Wietse Mol
Wietse Mol
Posts: 4
Hi Vadim, Tx for your reply, I have added credentials, and can also see them in the request, but get the same error. Hopefully this afternoon someone from support will join me in a webex session, I will keep you posted of the results.

Kind regards,

Wietse
0 link
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583


11/6/2012
Vadim @StresStimulus
Vadim @StresStimulus
Administrator
Posts: 583
Hi Wietse,
I would like to post a brief recap of our WebEx session, so it can help others in the community.
As you suggested in one of your messages, the issue was caused by the client (SAP BPC V10 client, Fiddler and StresStimulus) and the server being on the same machine. We determined that this is the case by re-issuing the login request from Fiddler and receiving the same 401 error. The screenshot below shows how to reissue a request in Fiddler.
 

Moving the client to a different machine solved the issue.
 
Cheers,
-Vadim
0 link
Wietse Mol
Wietse Mol
Posts: 4


11/6/2012
Wietse Mol
Wietse Mol
Posts: 4
Thanks Vadim,

Kind regards,
0 link






Copyright © 2017 Stimulus Technology